More on 01 Taurus electrical problems - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007 Forum for discussion of the Ford Taurus, Mercury Sable and Ford Taurus SHO. Covers vehicle years: 1986-2007

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 01-24-13, 04:35 PM Thread Starter
Registered User
 
Join Date: Aug 2010
Location: NORTH ALABAMA
Age: 59
Posts: 19
Smile More on 01 Taurus electrical problems

Oljo here again, looking for answers.In my previous post someone had mentioned my dash ground may need looking at.Before I pull the panel ,are there any ground locations I can check that might be related to the instrument panel?As I stated before My problems are,no instrument lights when the lights are on,only the turn signals ,which just stay lit.Now every now and then my daughter goes to start the car ,and nothing,no lights ,no buzzing,just nothing.Most of the time it starts just fine.Can anybody tell me their experiences with these problems.My 01 Taurus has been a tough ol gal, and I'd like to keep har awhile longer,until my daughter can get on her feet and buy a newer car.It's got about 195,000.thanks for listening,Oljoclark
OLJOCLARK is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 01-24-13, 08:31 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,283
Re: More on 01 Taurus electrical problems

Hard to say what could be amiss without being there to check it out. You can search the wiring diagrams here, | Repair Guides | Adjustable Pedals (2002) | Adjustable Pedals (2002) | AutoZone.com, and see what part could be causing the problem. Probably grounds but could be other connections too.

Bert
Bert is offline  
post #3 of 5 (permalink) Old 01-25-13, 03:45 AM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 13,942
Re: More on 01 Taurus electrical problems

Could possibly be a faulty ignition switch ?
R.S.LOGAN is offline  
post #4 of 5 (permalink) Old 01-25-13, 04:16 AM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 13,942
Re: More on 01 Taurus electrical problems

Regarding the dash lights , apparently this is quite common and in most cases is caused by the connections on the rear of the instrument cluster .Cleaning / checking the contacts and bending them very slightly to make tighter connection before snapping back the plugs into the cluster seems to be the solution .
R.S.LOGAN is offline  
post #5 of 5 (permalink) Old 01-28-13, 05:05 PM Thread Starter
Registered User
 
Join Date: Aug 2010
Location: NORTH ALABAMA
Age: 59
Posts: 19
Re: More on 01 Taurus electrical problems

Thanks,folks,for the replies.Waiting on a good day to go a step further.I'll sure post my findings.
OLJOCLARK is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome