OBDII says bad transmission and EGR - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007 Forum for discussion of the Ford Taurus, Mercury Sable and Ford Taurus SHO. Covers vehicle years: 1986-2007

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 10-28-04, 09:04 AM Thread Starter
Registered User
 
Join Date: Oct 2004
Posts: 1
OBDII says bad transmission and EGR

1997 Taurus (115000 miles), check engine light came on yesterday. Took the car to AutoZone today, they said the code came up as bad transmission and EGR problems. The car seems to be running fine. Should I take it to a mechanic so he can charge me tons of $ or just keep driving the car until it stops or is there something I can try to fix (or check) myself? Any input is greatly appreciated.

markfunston is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 11-07-04, 11:28 PM
Sho'n Off
 
98shotoy's Avatar
 
Join Date: Jul 2004
Location: Monroe, MI
Age: 39
Posts: 127
Re: OBDII says bad transmission and EGR

Quote:
Originally Posted by markfunston
1997 Taurus (115000 miles), check engine light came on yesterday. Took the car to AutoZone today, they said the code came up as bad transmission and EGR problems. The car seems to be running fine. Should I take it to a mechanic so he can charge me tons of $ or just keep driving the car until it stops or is there something I can try to fix (or check) myself? Any input is greatly appreciated.
I would find out what the code number is first. THem telling you a bad tranny and bad EGR can mean alot of things!!!! If you have the code number it would tell you more of what the problem is. If you get me a number I can tell you what exactly it says. Other then that I wouldnt do anything till ya find out.

Matt
1998 SHO
2004 F150 STX
2003 Explorer XLT Limited
Monroe, MI

I'd rather be judged by twelve then carried by six
98shotoy is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Symptoms of bad speed sensor? transmission problems- Ford Taurus TaurusLX Trans | Driveline 11 09-17-09 04:47 PM
P*ss Poor performance on hot days!!! the_scotsman General Tech 9 12-18-03 07:35 PM
Removing Code 67 chrispy General Tech 5 11-23-03 09:06 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome