pinging again - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007 Forum for discussion of the Ford Taurus, Mercury Sable and Ford Taurus SHO. Covers vehicle years: 1986-2007

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 11-11-2004, 20:16   #1 (permalink)
cyp
Registered User
 
Join Date: Nov 2004
Age: 39
Posts: 1
pinging again

Hi, I have a 99 Taurus Vulcan 3.0. Runs great excepting the "ping". Went to Ford, carbon removed, MAF, injectors, cleaned, spark plugs ok. No chance !
It pings like hell when the engine is heating, but only when i push the gas. Nothing when i run constantly speed the highway.
Doesn't work even with 94 octane.
What should I do?
Thanks a lot.
cyp is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2000 Windstar Pinging problem Digger Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar 1 07-12-2004 08:32
Xr8 Pinging Badly srv dt Australian Falcons 13 05-02-2004 16:05
sudden pinging... wasn't happening a few days ago eskyboi General Tech 8 03-28-2004 02:58
Zetec 2.0 engine pinging? Zetec Ford Focus Forum 7 01-02-2004 06:58
new 220kw pinging batbo6 General Tech 5 06-16-2002 15:55

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 07:31.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.