Running rough - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007 Forum for discussion of the Ford Taurus, Mercury Sable and Ford Taurus SHO. Covers vehicle years: 1986-2007

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 06-03-2010, 20:14   #1 (permalink)
Registered User
 
Join Date: Feb 2008
Posts: 23
Running rough

My wife's car (04 ford Taurus 3L duoteck ) has been running rough and now the check engine light came on borrowed a code reader from a friend and there was 4 faults

128 - coolant temp below thermosat regulating temp
301 - cylinder 1 missfire detected
316 - missfire detected 1st 1000 rev
354 - ignition coil D primary/secondary circuit malfunction

If anybody can give me some advise as to how to get this car running a little better before I atempt to take this vehicle on holidays.

Thanks
kidster is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-05-2010, 17:44   #2 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,803
Re: Running rough

I'd start with the missfire on cylinder #1. Have the plugs been changed lately? It could be the coil. You could try switching with a easier one and see if the missfire follows.
__________________
Bert
Bert is offline   Reply With Quote
Old 06-06-2010, 14:09   #3 (permalink)
Registered User
 
Sterling_Six's Avatar
 
Join Date: Aug 2008
Location: Green Bay, WI
Posts: 1,135
Re: Running rough

Quote:
Originally Posted by kidster View Post
My wife's car (04 ford Taurus 3L duoteck ) has been running rough and now the check engine light came on borrowed a code reader from a friend and there was 4 faults

128 - coolant temp below thermosat regulating temp
301 - cylinder 1 missfire detected
316 - missfire detected 1st 1000 rev
354 - ignition coil D primary/secondary circuit malfunction

If anybody can give me some advise as to how to get this car running a little better before I atempt to take this vehicle on holidays.

Thanks



Hello and good day:

This sounds like you have a bad Coil Pack on #1...I would replace the Coil Pack, and Replace the Thermostat...Rarely does the Sensor on the Thremo Housing go bad...If you get other OBDII Code one that it's that Sensor.
__________________
Good Luck and good repairing Sterling_6
"You know, just like in that Book, When Jesus beats up Moses to get Religion!!"
Sterling_Six is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 09:47.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.