Stumble on acceleration - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007 Forum for discussion of the Ford Taurus, Mercury Sable and Ford Taurus SHO. Covers vehicle years: 1986-2007

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 10-09-2010, 18:44   #1 (permalink)
Registered User
 
Join Date: Oct 2010
Posts: 2
confused Stumble on acceleration

My '93 Taurus (160K miles) ran great until it ate the distributor drive gear. I replaced the distributor and attached module, and set the timing to factory specs with the spark sensor unplugged. The car now starts easily, idles smoothly, and cruises great but has a massive bog off idle. The colder the engine, the worse the stumble. I have checked for vacuum leaks and found none. What would be the next likely problem?? Thanks
njbull is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-09-2010, 18:54   #2 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,809
Re: Stumble on acceleration

Unplug the MAF and see if it runs better.
__________________
Bert
Bert is offline   Reply With Quote
Old 10-18-2010, 09:38   #3 (permalink)
Registered User
 
Join Date: Oct 2010
Posts: 2
Re: Stumble on acceleration

I unplugged the MAF with little change. I then removed it and cleaned it with MAF cleaner. It still stumbles when cold but runs better than it used to warmed up. Should I replace the MAF or keep looking??
njbull is offline   Reply With Quote
Old 10-18-2010, 18:05   #4 (permalink)
Registered User
 
Sterling_Six's Avatar
 
Join Date: Aug 2008
Location: Green Bay, WI
Posts: 1,135
Re: Stumble on acceleration

Quote:
Originally Posted by njbull View Post
I unplugged the MAF with little change. I then removed it and cleaned it with MAF cleaner. It still stumbles when cold but runs better than it used to warmed up. Should I replace the MAF or keep looking??
Hello and good day:

I would recommed to Replace the MaF, and the IAC!!
__________________
Good Luck and good repairing Sterling_6
"You know, just like in that Book, When Jesus beats up Moses to get Religion!!"
Sterling_Six is offline   Reply With Quote
Old 10-18-2010, 21:00   #5 (permalink)
canuck
 
360ci's Avatar
 
Join Date: Nov 2007
Location: Waterloo
Posts: 2,475
Re: Stumble on acceleration

I'll second the IAC change. I know if it's not too carboned up you can clean it with carbon cleaner. But, be careful, if you move the plunger more than 1/4" or so, you'll need a new one. If you can clean it, you'll save yourself some bucks. Cheers.
__________________
'00 Durango R/T 360ci 290hp (modded); 138,500m
'06 Pontiac G6 GT 3.5L 220hp; 44,000m
'12 Chrysler 200 Limited 3.6L 283hp; 13,000m
'99 Taurus 3.0L 2V Vulcan 145hp; 154,300m - Traded
Amsoil in all vehicles!
360ci is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 08:48.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.