05 mustang gt electrical problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Mustang Forum This forum is for the discussion of all Ford Mustang models, including the Ford Mustang, Ford Mustang Convertible and Ford Mustang Coupe and all older/classic models and submodels.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 12-07-11, 07:27 PM Thread Starter
Registered User
 
Join Date: Dec 2011
Posts: 1
05 mustang gt electrical problem

My wifes gt has started to completly loose battery power and stall. First noticed a problem on the weekend when i moved her car that when i started it, the radio had switched to 540 and the clock had reset. When i switched the radio to fm all the presets were there. this has happened a couple of times now and has progressed. intermittantly the car will loose all 12v power and stall while driving! I changed the battery last year and replaced the positive cable end with a aftermarket one. After this last series of events i checked battery terminals and made sure all connections are tight. But tonight when she left work the radio was at 540 again!!! has any one had this problem or have any ideas on how to fix?

hvchris is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 12-17-11, 10:30 AM
Registered User
 
Join Date: Nov 2011
Posts: 18
Re: 05 mustang gt electrical problem

Check your battery......may b a bad ground...
calwhiterose is offline  
post #3 of 3 (permalink) Old 12-17-11, 10:40 AM
Registered User
 
Join Date: Nov 2011
Posts: 18
Re: 05 mustang gt electrical problem

Bert
I just wanted to let u know....that are 96 must problem was a bad pcm...so we are waiting to.have it repaired back east....Thanks for all your help on this...

Happy holidays........Walter
calwhiterose is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Mustang Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome