1999 Mustang 3.8L V6 Problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Mustang Forum This forum is for the discussion of all Ford Mustang models, including the Ford Mustang, Ford Mustang Convertible and Ford Mustang Coupe and all older/classic models and submodels.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 01-14-07, 04:16 PM Thread Starter
Registered User
 
Join Date: Jan 2007
Posts: 9
1999 Mustang 3.8L V6 Problem

Recently while driving at highway speed the car started slowing down and would not respond to accelerator pedal input. Coasted to side of road where engine ran rough and died. Restarted car without a problem and drove home. Has done it two more times exactly the same way. No touble codes set and scan says "passed". Car has 140k miles and until now has run perfectly. Have no idea if fuel filter has ever been changed but will change it tomorrow.

Any ideas?
mikeh is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 01-20-07, 09:18 AM Thread Starter
Registered User
 
Join Date: Jan 2007
Posts: 9
Re: 1999 Mustang 3.8L V6 Problem

Tough one mikeh. Fuel filter would be the first on my list too. Still think that you will probably need to check the fuel pump.
mikeh is offline  
post #3 of 3 (permalink) Old 01-20-07, 09:22 AM Thread Starter
Registered User
 
Join Date: Jan 2007
Posts: 9
Re: 1999 Mustang 3.8L V6 Problem

Fuel filter was "clean". Check of fuel pressure shows that it is within spec but does not respond smoothly to the engine demand. Changed the fuel pump and now the pressure is not only correct but is responding properly. Acid test will be when the fuel level drops below 4 gallons.

Thanks to all who offered suggestions.
mikeh is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Mustang Forum
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome