2002 3.8L mustang sweeking coming from engine. - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Mustang Forum This forum is for the discussion of all Ford Mustang models, including the Ford Mustang, Ford Mustang Convertible and Ford Mustang Coupe and all older/classic models and submodels.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 08-31-08, 06:06 PM Thread Starter
Registered User
 
Join Date: Aug 2008
Posts: 1
2002 3.8L mustang sweeking coming from engine.

I've got a sqeaking sound coming from the front of the engine. As a troubleshooting step I removed the belt so that I can isolate pullies etc... I started the car in the driveway, with manual transmission in nutral. The noise is still there. I checked and there is clearance between the crank poisition sensor. The sound is like a bearing gone bad, ie much like the dying water pump sound, yet again it's not driven since the belt is off and the car is stationary in the driveway squaking its little heart out...
mustmon is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Mustang Forum
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome