5.4Litre, 3valve engine losing power at low revs - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Mustang Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Mustang Forum This forum is for the discussion of all Ford Mustang models, including the Ford Mustang, Ford Mustang Convertible and Ford Mustang Coupe and all older/classic models and submodels.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 09-06-2008, 01:50   #1 (permalink)
TECHNINE & NOMIS UK
 
oneloveofboard's Avatar
 
Join Date: Sep 2008
Location: MANCHESTER, UK
Posts: 14
5.4Litre, 3valve engine losing power at low revs

Ive posted this in here aswell, as I know the Mustang uses the same 5.4 3v engine as the Navigator, and there are probably more people on this forum who know about there this engine.

Hi please can someone help me on this,

I live in the UK and I drive a 2005 Lincoln Navigator which is fitted with the 5.4 3v engine, I do aprox 25 to 30K miles per year and change the oil and filters and transmission fluid regular. And early on this year I changed over to the Champion 7989 plugs after reading problems of the factory ones snapping off.

Over the last month the engine has become louder with a tapping noise when idling at both cold and running temperature, and it is running with a slight lumpy feel at low revs.

If im cruising and revs are between 1000 and 2500 the engine feels rough, but not miss firing just slightly off, and the power seems to have decreased, but if I floor it and drops down another geer the revs shoot up and off it goes with no problems.

I am finding that on take off, and if im accellerating up a hill, for a split second the power drops and then it feels like its struggling to pick up, but again if I floor it, it will drop to another gear and take off as normal.

Can anyone give me any tips as to what this might be, as in the UK we dont have any lincoln dealers and the ford dealers wont touch imported cars. And local garages dont want to look at it either.

Any help would be good before I resort to ripping it to bits,

Thanks
onelove
oneloveofboard is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Mustang Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 02:11.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.