85 Mustang Highbeam problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Mustang Forum This forum is for the discussion of all Ford Mustang models, including the Ford Mustang, Ford Mustang Convertible and Ford Mustang Coupe and all older/classic models and submodels.

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 02-29-08, 08:00 AM Thread Starter
Registered User
Join Date: Feb 2008
Posts: 1
85 Mustang Highbeam problem

We have an 85 Mustang Convertible that we are trying to fix up for my step-daughter to drive. There is a problem with the highbeams that we can't figure out and thought maybe someone could offer an opinion. High beams will work for about 20 minutes and then all lights cut out. Flip the switch to low beams and those come back on. We replaced the switch in the column, also replaced the headlights, same results. When the switch is held, the high beams will stay on. Also, they sometimes will go back on after being off. Any thoughts on what else could be the problem? Won't pass inspection until we get it fixed and really hate the thought of a huge repair bill. Thanks for your input.
Conley0619 is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Mustang Forum
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome