93 Mustang 5.0 problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Mustang Forum This forum is for the discussion of all Ford Mustang models, including the Ford Mustang, Ford Mustang Convertible and Ford Mustang Coupe and all older/classic models and submodels.

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 09-12-09, 02:31 PM Thread Starter
Registered User
Join Date: Apr 2004
Posts: 6
confused 93 Mustang 5.0 problem

I have a 93 Mustang LX w/ 5.0L engine with 103,000 miles on it. Recently the engine began losing compression and backfiring when in low gear, either starting from a dead stop or going up a hill). It happens when the engine is cold or warm.

Any suggestions on what the problem is?

Jimustang is offline  
Sponsored Links
post #2 of 3 (permalink) Old 09-12-09, 06:01 PM
2002 F150 XLT
Bert's Avatar
Join Date: Nov 2008
Location: Oregon
Posts: 10,249
Re: 93 Mustang 5.0 problem

Has it had spark plugs or fuel filter lately? Any check engine light on? Cleasning the IAC and MAF also help them run better.
Bert is offline  
post #3 of 3 (permalink) Old 09-28-09, 03:49 PM
Registered User
Join Date: Sep 2009
Posts: 5
Re: 93 Mustang 5.0 problem

You said it's losing compression. Is that a gut feeling or did you do a compression test? If so, usually it's 1 or 2 cylinders which are low and require further diagnosis.
<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" /><o:p></o:p>
If compression is actually OK, first place to check a misfire is the secondary portion of the ignition system (plugs, wires, coil).
car questions is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Mustang Forum
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome