95 5.0 Mustang Starting / Running Problems - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Mustang Forum This forum is for the discussion of all Ford Mustang models, including the Ford Mustang, Ford Mustang Convertible and Ford Mustang Coupe and all older/classic models and submodels.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 08-04-06, 08:21 AM Thread Starter
Registered User
 
Join Date: Aug 2006
Posts: 1
95 5.0 Mustang Starting / Running Problems

I have a 95 GT that is having a hard problem starting. It just cranks and cranks, ocassionally starting. Once it does start If I try and press the accelartor hard it spits and sputters and dies. It seems as if it's not getting enough fuel. If I just ease into the pedal it seems fine. I have replaced the fuel pump, the Coolant Tempature Sensor, the Ignition coil. I am thinking that it might be the Idle Air Control Valve.

Any one else have any thoughts?

Thanks,

Scott

smeverts is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 08-04-06, 11:44 AM
Hi-Tech Redneck
 
Johnny Mullet's Avatar
 
Join Date: Jun 2006
Location: Ashtabula, Ohio
Age: 45
Posts: 1,486
Re: 95 5.0 Mustang Starting / Running Problems

Could also be a MAF sensor or a TPS. Is the check engine light on? If so, can you get a scan done and post the code?
Johnny Mullet is offline  
post #3 of 3 (permalink) Old 11-09-06, 04:55 AM
lone_wolf_901
 
lone_wolf_901's Avatar
 
Join Date: Nov 2006
Location: Columbia, SC
Age: 34
Posts: 25
Re: 95 5.0 Mustang Starting / Running Problems

It could also be a small leak in your fuel delivery line. Or clogged injectors.

If you can't run with the big dog's. Then chase the smaller one's.
lone_wolf_901 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Mustang Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome