'99 Mustang A/C not working - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Mustang Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto EscrowInsurance

Ford Mustang Forum This forum is for the discussion of all Ford Mustang models, including the Ford Mustang, Ford Mustang Convertible and Ford Mustang Coupe and all older/classic models and submodels.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 06-29-2008, 16:27   #1 (permalink)
Registered User
 
Join Date: Jun 2008
Posts: 1
'99 Mustang A/C not working

I have a '99 Mustang 3.8L. The Air conditioning isn't working on it. I've checked the coolant/freon and it is fine. All that happens when it is turned on is it blows hot air no matter what the setting is. I think it is the compressor. Does anybody have any suggestions?
drumguy836 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-03-2009, 07:24   #2 (permalink)
Registered User
 
Join Date: May 2009
Posts: 1
Re: '99 Mustang A/C not working

Im having the same problem with an explorer. Does the compressor turn on? also are you able to check for codes?
CarCrazy85 is offline   Reply With Quote
Old 05-25-2009, 18:50   #3 (permalink)
Registered User
 
Join Date: May 2009
Posts: 3
Re: '99 Mustang A/C not working

have you checked the compressor clutch yetafter you turn on your a/c look under the hood you should here a click which is the clutch locking in that will start the compressor. you can also hook a reading on the a/c it shoudl engange around 70psi adn stay around 40psi
normanharrall is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Mustang Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 10:09.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.