engine won't start. - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Mustang Forum This forum is for the discussion of all Ford Mustang models, including the Ford Mustang, Ford Mustang Convertible and Ford Mustang Coupe and all older/classic models and submodels.

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 09-04-07, 09:23 PM Thread Starter
Registered User
Join Date: Sep 2007
Posts: 3
engine won't start.

Hi every one. I hope to get some help here.Now here is my problem.
I have a 1990 Ford Mustang GT, 5.0L V8 FI OHV. Car was sitting for some time,about year & half, now it won't start.
Things I replaced. 1) fuel pump 2) air flow sensor 3) termo time switch 4) fuel pressure regulator 5) Throttle Position sensor. 6) distributor & high tension leads. Also fresh gas.
Engine will start when a little gas is pour in throttle body. But run rough, and backfire. Could it be injectors?
Thanks in advance,
raj is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Mustang Forum
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome