Help!! I need answers - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Mustang Forum This forum is for the discussion of all Ford Mustang models, including the Ford Mustang, Ford Mustang Convertible and Ford Mustang Coupe and all older/classic models and submodels.

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 09-01-06, 11:07 PM Thread Starter
Registered User
Join Date: Sep 2006
Posts: 1
confused Help!! I need answers

Hi guys! Got a 1997 plain Mustang, 3.8L I guess. Bought it cause the price was right. I've had to have the cam sensor replaced three times this week. Taking it back tomorrow for a fourth time. The engine light keeps coming on and the diagnosis is always cam sensor. I read in the book that if the engine light comes on it could mean that I have an emissions problem. My tailpipe has developed some small holes. What do you think? Thanks! Oh, I'm Select by the way.
select is offline  
Sponsored Links
post #2 of 3 (permalink) Old 09-02-06, 12:07 PM
Registered User
Join Date: Sep 2006
Location: Ontario, CA
Posts: 5
Re: Help!! I need answers

Obviously, at this point, the problem isn't the cam sensor. It could be something electrical - upstream or downstream - of the sensor. It's time for your shop to do some actual diagnosos and inspection, rather than blindly replacing a part. If they "don't know" what to do, it's time to find another shop.
Hoofbeatz is offline  
post #3 of 3 (permalink) Old 11-09-06, 05:51 AM
lone_wolf_901's Avatar
Join Date: Nov 2006
Location: Columbia, SC
Age: 33
Posts: 25
Re: Help!! I need answers

Okay its not the cam sensor unless they installed the wrong type of cam sensor. But other than that you should try a second opion from another shop. Tell them what happened and what the other shop did. The more information you give them the better the results.

If you can't run with the big dog's. Then chase the smaller one's.
lone_wolf_901 is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Mustang Forum
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome