installed 76mm C&L- now have hesitation when opening full throlle on 91 5.0 Mustang - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Mustang Forum This forum is for the discussion of all Ford Mustang models, including the Ford Mustang, Ford Mustang Convertible and Ford Mustang Coupe and all older/classic models and submodels.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 09-19-08, 11:16 AM Thread Starter
Thing 1
 
1meanGT's Avatar
 
Join Date: Jan 2007
Location: Northern Iowa
Posts: 174
confused installed 76mm C&L- now have hesitation when opening full throlle on 91 5.0 Mustang

This problem has me stumped. I have a 91 Mustang GT vert with 70k and 5.0 Auto.

The car suddenly has a slight hesitation. When I open the throttle wide open, the car starts to break loose, then you can feel the engine hold steady (speed is about 25mph) for about a half second- then she rips loose with no problems.

I do not have any backfires or predetonation.

I have done the following mods that may affect this problem:

Removed smog system completely and rerouted belt.
Installed 3.73 gears- VERY NICE!
9mm Ford Racing wires
new cap/rotor
K&N filter in factory box with silencer removed
factory plugs set at .60
2.5" MAC from CAT back.
A9P (factory)

Problems started when I added the following:

76mm MAF with 76mm inlet pipe w/ 19lb calibration tube and I reused the original sensor. I put back the original MAF and the problem went away- but could definitely notice the change in HP.


Since this mod- but after the problem- I have installed 24lb Ford racing injectors, 24lb calibration tube, Kirban fuel regulator and new vacuum hoses. No change in the problem. I now can't reuse the orginal MAF to make the problem go away due to the injector change.

I have tried 10-17 degrees of timing- no change.
TPS is at .98
Fuel pressure is 40lbs with vacuum off- and about 28 or so with it on.

I have a list of upgrades, but want to correct this problem before I jump ahead.

Anyone have any ideas?

1meanGT is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 09-27-08, 07:17 PM Thread Starter
Thing 1
 
1meanGT's Avatar
 
Join Date: Jan 2007
Location: Northern Iowa
Posts: 174
Re: installed 76mm C&L- now have hesitation when opening full throlle on 91 5.0 Musta

Tried 92 octane today- gone! Suspect lean fuel condition now since higher octane burns slower.
1meanGT is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Mustang Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome