mustang trouble :( - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Mustang Forum This forum is for the discussion of all Ford Mustang models, including the Ford Mustang, Ford Mustang Convertible and Ford Mustang Coupe and all older/classic models and submodels.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 04-21-08, 09:33 PM Thread Starter
Registered User
 
Join Date: Apr 2008
Posts: 1
confused mustang trouble :(

1994 Ford Mustang
v6 3.8
170,000miles

won't engage into overdrive

accelerates good until about 40-45 mph then it doesn't let me accelerate anymore and sends rpms through the roof.

If i turn the overdrive off it will let me go faster than 40-45 but the rpms are really high.

I took it to autozone to had them give me codes for why the check engine light is on and came back with codes 1151 and 1152

I recently replaced the computer also.

If you have any idea what could possibly be wrong, that'd be great.




jillianellen is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 04-23-08, 12:45 PM
canuck
 
360ci's Avatar
 
Join Date: Nov 2007
Location: Waterloo
Posts: 2,481
Re: mustang trouble :(

If you have a repair manual, I'd replace the sensors listed below or bring it to a shop:

P1151 - Lack of Upstream Heated Oxygen Sensor Switch - Sensor Indicates Lean - Bank No. 2

P1152 - Lack of Upstream Heated Oxygen Sensor Switch - Sensor Indicates Rich - Bank No. 2

'11 Ram Quad Cab 4x4 SXT 5.7L HEMI (stock); 48,500m
'06 Pontiac G6 GT 3.5L 220hp; 64,000m
'12 Chrysler 200 Limited 3.6L 283hp; 28,000m
'99 Taurus 3.0L 2V Vulcan 145hp; 154,300m - Traded
Amsoil in all vehicles!
360ci is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Mustang Forum
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome