would like some help please - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Mustang Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Mustang Forum This forum is for the discussion of all Ford Mustang models, including the Ford Mustang, Ford Mustang Convertible and Ford Mustang Coupe and all older/classic models and submodels.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-28-2007, 15:33   #1 (permalink)
Registered User
 
Join Date: Mar 2007
Location: clarksville tn
Posts: 3
confused would like some help please

i have a 1992 convertible 2.3L, and im having all kinds of problems with it right now. its idling very low and sometimes stalling out, engine shakes, sounds terrible, when i hold the brake to shift into drive, park, etc. ive been going thru alot of gas, barely gettin 10-12 miles per gallon. i have changed the o2 sensor, spark plugs, plug wires, mass airflow sensor, pcv valve, fuel filter, egr valve and the sensor that attaches to it, among other things, thats just all i can remember at the moment. its still runnin terrible, i can barely get to 55 mph and to get to that takes forever. ive had the transmission checked, i just had a new one put on less than 4 yrs ago and everything checks out. i had all new exhaust pipes, muffler, everything except the catalytic converter, put on less than 6 months ago. my fuel pressure is reading at 32, not sure exactly what its supposed to be, but u can hear the fuel pump kick on when the car is started, just like it normally does. i have been told it may be the ignition control module???? before i spend another 149.00 i would like to know how i can be sure or even a couple more opinions would help! thanks
dstrbdbyu is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-28-2007, 17:23   #2 (permalink)
Registered User
 
Join Date: Mar 2007
Location: Dallas Center, Iowa
Posts: 24
Re: would like some help please

It could be your ignition control module, it also could be the MAF sensor. That's the bad thing it could be any number of sensors. But it sounds like you checked most of them. But do this, as hard as it is to believe check all your vaccum lines. Because we had the same problem out of one of our mustangs and we had a lose vaccum line. I hope that helps.
Bossnutt is offline   Reply With Quote
Old 03-28-2007, 17:55   #3 (permalink)
Registered User
 
Join Date: Mar 2007
Location: clarksville tn
Posts: 3
Re: would like some help please

i changed the maf sensor already, im not sure if its something that will come up on the codes or not, but it did not. ive also had the vacuum lines all checked more than once, 1 of which had to be relaced. i had tried to find more info about the ignition module but it sounds like a bunch of crazy crap to me
dstrbdbyu is offline   Reply With Quote
Old 03-28-2007, 18:03   #4 (permalink)
Registered User
 
Join Date: Mar 2007
Location: Dallas Center, Iowa
Posts: 24
Re: would like some help please

Have you changed the IAC module?
Bossnutt is offline   Reply With Quote
Old 03-28-2007, 19:43   #5 (permalink)
Registered User
 
Join Date: Mar 2007
Location: clarksville tn
Posts: 3
Re: would like some help please

i dont think so, ill have to look thru my receipts! :)
dstrbdbyu is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Mustang Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 21:31.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.