05 Ford Focus ZXW - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Focus Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Focus Forum Forum for the discussion of the Ford Focus

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 04-18-2008, 12:58   #1 (permalink)
Registered User
 
Join Date: Apr 2008
Posts: 1
05 Ford Focus ZXW

Hi there!
The brake lights went out on my 2005 Ford Focus ZXW. I changed the bulbs and they still don't work. The overhead one is working fine. I have an extended warranty but I am out of town for a couple weeks and don't want to pay the deductible if I don't have to. Any help would be great! I know how mechanics expect us chicks to be clueless and if Ican't fix it I want to at least have some idea what I am talking about when I walk in the place! :o)
Thanks so much!
shelbie71 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-27-2008, 20:11   #2 (permalink)
canuck
 
360ci's Avatar
 
Join Date: Nov 2007
Location: Waterloo
Posts: 2,475
Re: 05 Ford Focus ZXW

I'd start with the basics and check to make sure the fuses are all in tight and secure, and check for any that might have blown. It should state in the owners manual what fuse is for what circuit, to help narrow down the problem. If it's not a fuse issue and you know how to use a multi-meter then I'd ohm the problem out unless anyone else can suggest something better?
__________________
'00 Durango R/T 360ci 290hp (modded); 138,500m
'06 Pontiac G6 GT 3.5L 220hp; 44,000m
'12 Chrysler 200 Limited 3.6L 283hp; 13,000m
'99 Taurus 3.0L 2V Vulcan 145hp; 154,300m - Traded
Amsoil in all vehicles!
360ci is offline   Reply With Quote
Old 05-03-2008, 11:49   #3 (permalink)
Registered User
 
Join Date: May 2008
Posts: 1
Re: 05 Ford Focus ZXW

Heard somewhere y have a problem with the wires breaking in the harness for the liftgate from excessive use. you might want to have that checked out. Good luck.
zeno5 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Focus Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 08:28.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.