2000 Focus transmission slipping - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Focus Forum Forum for the discussion of the Ford Focus

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 05-03-05, 05:01 PM
Doug White
Posts: n/a
2000 Focus transmission slipping

2000 Ford Focus SE Wagon, Z-Tec engine. Automatic transmission

Started noticing a little slipping in the tranny in this car. Also car
would shudder a little when pulling off from a stop. Problem was worse
after warming up. transmission fluid level was good.

Took it to the dealer today. They ended up replacing the spark plugs and
the ignition coil pack. Total repair USD 340.

Dealer says the coil was so weak it was not firing the ignition
properly. It runs well now after repair. Dealer said they don't see
many transmission problems in these cars.

All the best,
Doug White
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Focus Forum
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome