2004 Focus TDCi problems - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Focus Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Focus Forum Forum for the discussion of the Ford Focus

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 11-04-2009, 15:20   #1 (permalink)
Registered User
 
Join Date: Nov 2009
Posts: 1
frown 2004 Focus TDCi problems

Hey,

New here, first post.

I just had my EGR valve / manifold replaced at the weekend as the garage said that it was broken, now I have a different problem.

When i start the engine, the engine warning light pops up, the mileometer flashs dashs (----) across it, and the RPM gage drops to 0 from its real valve, then spikes back up.

This doesnt always happen when starting the engine, sometimes its a bit later in the trip, the above will repeat. Whenever it is though, the engine warning light stays on for 5 - 10 seconds and then goes off when I have slowed down.

Does anyone have any ideas what it could be? Could the garage not have reset the computer when they changed the EGR valve? Could it be some sensor gone funny?

Can i boot it into test mode to see any error codes coming back?

Thanks,
David.
dave164 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-05-2009, 08:41   #2 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,847
Re: 2004 Focus TDCi problems

Have you spoken with the garage and told them what it's doing now? It's possible there's a poor connection some where. You also should be able to get a code for the problem. Autozone will check for free.

Welcome to the forums.
Bert is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Focus Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 05:55.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.