Both front side lights not working - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Focus Forum Forum for the discussion of the Ford Focus

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-30-12, 06:04 AM Thread Starter
Registered User
Join Date: Aug 2007
Posts: 2
Both front side lights not working


Both front side lights on my wife's 2003 Focus are not working.

With the engine running and the rotating switch set to side lights etc, I have checked the following.

Both bulbs are working
Both fuses are good
There is power to both fuses in the passenger foot well (no power when lights are switched off).

To me this rules out the switch and the fuses and the bulbs.

Not sure where else to check.

Any help you can give would be most useful.



Last edited by nickorossa; 03-30-12 at 06:34 AM. Reason: Idiot in the room. Problem solved.
nickorossa is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Focus Forum
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome