Focus V heated screen not working help - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Focus Forum Forum for the discussion of the Ford Focus

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 02-03-11, 05:00 PM Thread Starter
Registered User
 
Join Date: Feb 2011
Posts: 2
Focus V heated screen not working help

hi all

i have a focus v reg with a heated screen, i have just had a new screen fitted on mondat 31/01/2011.
but i used it on tuesday morning to clear the heavy frost and only the passengers side worked, the old screen had the same prob
the fuses are ok and the relay i think is.
the screen has a lead on the botton right and left which was connected on fitting.

any ideas

also i dont have a hayes manuel.

many thank for your time

ian.

sweenitodd is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 02-04-11, 06:47 AM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 15,172
Re: heated screen not working help

There are usually two seperate fuses (40amp?) , one for each side . Both o.k ? If so , you will have to check the ribbons / supply to screen and connections for corrosion .
R.S.LOGAN is offline  
post #3 of 4 (permalink) Old 02-04-11, 08:33 AM Thread Starter
Registered User
 
Join Date: Feb 2011
Posts: 2
Re: heated screen not working help

hi thanks for the reply

do you know what number the fuses are and if they are ok how do i get to the ribbons to check for corrosion

sorry im fix pcs and not cars so im a tat dumb ass
sweenitodd is offline  
post #4 of 4 (permalink) Old 02-04-11, 08:54 AM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 15,172
Re: heated screen not working help

On some models it was No 14 for the RHS and No 16 for the LHS both 40 amps. You had to remove the wipers and scuttle panel to see the foil connectors and ribbons / wiring / connection .Hope this helps .
R.S.LOGAN is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Focus Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome