Please Help Me!!! - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Focus Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Focus Forum Forum for the discussion of the Ford Focus

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-23-2006, 22:57   #1 (permalink)
Registered User
 
Join Date: Feb 2006
Posts: 1
Please Help Me!!!

i have a 2000 ford focus. i went out to start it today and i turned the key and it made this clicking noise and did not start and the speedometer and gas guage pointers were going crazy. then i put on jumper cables and tried to start it and it turned over the motor but it seemed not to have enough energy to start. So i removed the battery and charged it. i put it back it and turned the key and it did not make any noise at all and didnt start.... all the lights and electronics work though. please help me
Brian32 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-23-2006, 23:08   #2 (permalink)
Registered User
 
tufLTD's Avatar
 
Join Date: Apr 2005
Location: Caloundra, Queensland
Age: 52
Posts: 240
Re: Please Help Me!!!

There's a couple of things that could cause your problems.
1. A dead battery. Try another good battery. This would seem like the most likely cause.
2. Starter motor.
3. Dirty battery terminals. Give them a good clean with a wire brush.
tufLTD is offline   Reply With Quote
Old 02-24-2006, 11:47   #3 (permalink)
Unregistered
Guest
 
Posts: n/a
Re: Please Help Me!!!

it was the battery terminals... after i cleaned them off it started right up. thanks alot
  Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Focus Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 00:35.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.