Please Help Me!!! - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Focus Forum Forum for the discussion of the Ford Focus

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 02-23-06, 11:57 PM Thread Starter
Registered User
Join Date: Feb 2006
Posts: 1
Please Help Me!!!

i have a 2000 ford focus. i went out to start it today and i turned the key and it made this clicking noise and did not start and the speedometer and gas guage pointers were going crazy. then i put on jumper cables and tried to start it and it turned over the motor but it seemed not to have enough energy to start. So i removed the battery and charged it. i put it back it and turned the key and it did not make any noise at all and didnt start.... all the lights and electronics work though. please help me
Brian32 is offline  
Sponsored Links
post #2 of 3 (permalink) Old 02-24-06, 12:08 AM
Registered User
tufLTD's Avatar
Join Date: Apr 2005
Location: Caloundra, Queensland
Age: 53
Posts: 240
Re: Please Help Me!!!

There's a couple of things that could cause your problems.
1. A dead battery. Try another good battery. This would seem like the most likely cause.
2. Starter motor.
3. Dirty battery terminals. Give them a good clean with a wire brush.
tufLTD is offline  
post #3 of 3 (permalink) Old 02-24-06, 12:47 PM
Posts: n/a
Re: Please Help Me!!!

it was the battery terminals... after i cleaned them off it started right up. thanks alot
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Focus Forum
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome