Sputtering and Low Power - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Focus Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Focus Forum Forum for the discussion of the Ford Focus

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-26-2008, 03:23   #1 (permalink)
Registered User
 
Join Date: Feb 2008
Posts: 1
Sputtering and Low Power

Ok last week my car went into limp mode and started spluttering and not letting have much power to move or accelerate, i took it to a ford garage and they hooked it up to the machine, they told me it was the coil pack, spark plugs and leads that were damaged , so i took the car home and i renewed the damaged parts, everythign seemed to be fine untill later the next day after a drive about, my car started to make a rattling noise, i checked it out and it sounded liek the cat converter had blown, so i proceded to get that replaced, once i had done so i started her up and she sounded as sweet as a nut.

Until i drove it i relised i still had no power and the car was making a sputtering sound as if it was back firing or miss firing, i read on some pages that maybe the 02 sensor was damaged as well with the cat, so i renewed that, and still the problem remains.

I also have been told that the MAF sensor could just need cleaning, but alas i cant find it under my hood,

im at my wits end i cant for the love of me think what could be wrong.

anyone got any sure fire answers??

My car is a FORD FOCUS 2003 1.6 ZETEC SE
<!-- / message -->
madgaz182 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-06-2008, 19:37   #2 (permalink)
canuck
 
360ci's Avatar
 
Join Date: Nov 2007
Location: Waterloo
Posts: 2,475
Re: Sputtering and Low Power

MAF sensor should be located around the air intake tube. Make sure your air filter is clean. You mentioned a rattling noise. Does it rattle at idle only? If so, try a higher grade of fuel once your tank gets low (add 3-4 gallons of mid grade, or hi-test) and see if that helps.
__________________
'00 Durango R/T 360ci 290hp (modded); 138,500m
'06 Pontiac G6 GT 3.5L 220hp; 44,000m
'12 Chrysler 200 Limited 3.6L 283hp; 13,000m
'99 Taurus 3.0L 2V Vulcan 145hp; 154,300m - Traded
Amsoil in all vehicles!
360ci is offline   Reply With Quote
Old 03-15-2008, 02:39   #3 (permalink)
Registered User
 
Fordtech.'s Avatar
 
Join Date: Apr 2003
Location: UK
Posts: 688
Re: Sputtering and Low Power

If the cats been faulty for a while, it's possible parts have broken up and have become lodged further down the exhaust causing a blockage.
Fordtech. is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Focus Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 23:24.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.