'01 Ranger w/ 4x4 Problems - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Ranger Forum Forum for discussion of the Ford Ranger.

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 01-09-09, 08:07 PM Thread Starter
Registered User
Join Date: Jan 2009
Location: Anchorage, AK
Age: 29
Posts: 3
'01 Ranger w/ 4x4 Problems

I have a 2001 Ranger that''s having some issues. First of all I have a leak from my front driveshaft. I believe that could be a pinion seal. Second, my four wheel drive is noisy. It rattles when engaged and taking off after a stop it acts like it''s not fully engaged because it seems to pop in with a noisy crack. Then, when I turn the switch back to 2 wheel drive, it doesn''t want to disengage. What''s going on here. Any help would be greatly appreciated. Thanks.
dngranger is offline  
Sponsored Links
post #2 of 3 (permalink) Old 01-17-09, 08:16 PM
360ci's Avatar
Join Date: Nov 2007
Location: Waterloo
Posts: 2,477
Re: '01 Ranger w/ 4x4 Problems

Service the axles and transfer case with good name brand fluid. Personally, I prefer Amsoil (ATF in transfer case and 75W90 in transfer cases), but any good oil will do. I'd check your front U-joints, if you can turn the axle by hand even ever so slight, you'll need new u-joints. As for changing the transfer case, try driving the vehicle in reverse and then change the transfer case to the desired position. Depending on the abuse the truck has seen and the miles driven, it may take a good 100m before the transfer case disengages. A leaky pinion seal is likely if the differential case is on tight. A good way to check for leaks is to wash the oil off and wait a couple days to see where the new oil is seeping out of. I know with the wintery weather it won't be easy!

'00 Durango R/T 360ci 290hp (modded); 138,500m
'06 Pontiac G6 GT 3.5L 220hp; 44,000m
'12 Chrysler 200 Limited 3.6L 283hp; 13,000m
'99 Taurus 3.0L 2V Vulcan 145hp; 154,300m - Traded
Amsoil in all vehicles!
360ci is offline  
post #3 of 3 (permalink) Old 01-20-09, 03:38 AM Thread Starter
Registered User
Join Date: Jan 2009
Location: Anchorage, AK
Age: 29
Posts: 3
Re: '01 Ranger w/ 4x4 Problems

Thanks. If I go in reverse, the 4-wheel disengages fine but I don't know why it won't disengage normally. This truck has pretty much been through hell and back. Pulling boats, campers, getting sunk in mud and snow, pulling people out and even once pulled a fed ex truck up an icy hill. So it's not really surprising that it's starting to act up. I've serviced the transfer case with quaker state gear oil but i haven't done anything with the axles yet. I will try servicing them and check the u-joints. Thanks again.
dngranger is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome