02 Ranger 2.3 weird problems - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Ranger Forum Forum for discussion of the Ford Ranger.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 01-17-10, 02:14 PM Thread Starter
Registered User
 
Join Date: Jan 2010
Posts: 2
02 Ranger 2.3 weird problems

2002 Ranger 2.3, standard trans, runs really rough when cold. Sets codes po352, and cylinder 2 and 3 misfire codes. Takes 20 min to warm up. When fully warm temp sensor is reading 240 and holds steady. When fully warm runs fine. When computer is in open loop runs rough then switches to closed loop it runs fine. I really need help with this one.

tuna1664 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 01-17-10, 03:24 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,312
Re: 02 Ranger 2.3 weird problems

Have you fixed the missfire? For some running problems, cleaning the MAF with the MAF cleaner helps.

Bert
Bert is offline  
post #3 of 4 (permalink) Old 01-17-10, 03:28 PM Thread Starter
Registered User
 
Join Date: Jan 2010
Posts: 2
Re: 02 Ranger 2.3 weird problems

Quote:
Originally Posted by rtg143 View Post
Have you fixed the missfire? For some running problems, cleaning the MAF with the MAF cleaner helps.
No but why would the MAF make it miss on only 2 and 3? im just confused. im glad i finally got a response though. and it runs fine when warmed up. and the coolant temp way to high.
tuna1664 is offline  
post #4 of 4 (permalink) Old 01-17-10, 05:33 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,312
Re: 02 Ranger 2.3 weird problems

It shouldn't have anything to do with the miss. The code P0352 is the coil #2 circuit. The coil may need replacing or the wiring has a problem. It could also give the misfire code.

Bert
Bert is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome