04 Ford Ranger 3 Liter oil problems - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Ranger Forum Forum for discussion of the Ford Ranger.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 12-23-2008, 10:20   #1 (permalink)
Registered User
 
Join Date: Dec 2008
Posts: 2
Question 04 Ford Ranger 3 Liter oil problems

I have an 04 Ranger with 3 liter when the truck is idle the oil light comes on and the truck does not pump oil but when i get it over 2 grand the oil light goes away and the truck runs fine. I have replaced the oil pump and the gear on the cam the drives the oil pump. Any suggestions???????????????
mfoster is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-23-2008, 13:54   #2 (permalink)
Registered User
 
jglen490's Avatar
 
Join Date: Jul 2008
Location: Montgomery
Age: 67
Posts: 52
Re: 04 Ford Ranger 3 Liter oil problems

The sensor could be bad.
__________________
I feel more like I do now than I did when I got here.
jglen490 is offline   Reply With Quote
Old 12-23-2008, 15:49   #3 (permalink)
Registered User
 
Join Date: Dec 2008
Posts: 2
Re: 04 Ford Ranger 3 Liter oil problems

would the sensor cause the pump to stop working at low rpm's? I am told that wouldn't cause this issue???????????????
mfoster is offline   Reply With Quote
Old 12-23-2008, 16:19   #4 (permalink)
Administrator
 
Join Date: Sep 2006
Location: Arkansas
Posts: 5,994
Re: 04 Ford Ranger 3 Liter oil problems

I would replace the sending unit first and see if the problem goes away.

If it does not then you probably have excessive wear at the main bearings.

Also, I'm sure the pump is pumping "some" at low RPM's just not enough to keep the low oil light off.
jwko is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 05:19.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.