1992 Automatic Transmission help - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Ranger Forum Forum for discussion of the Ford Ranger.

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 10-16-05, 07:46 AM Thread Starter
Registered User
Join Date: Oct 2005
Posts: 2
1992 Automatic Transmission help

I just pulled my old automatic transmission from my 1992 Ranger V6 3.0. I bought another one from the junk yard and put it in along with a new kickdown cable. As far as I know I hooked everything back up right. At the same time I installed a new transmission cooler because the old one cracked. My fluid level seems to be reading at level, however I can manually shift to each gear, but when I attempt to drive it will not shift when accellerated. If I manually put it in second then to drive while accelerating it drops backto first and stays there.

Any ideas what went wrong?
jhuntl01 is offline  
Sponsored Links
post #2 of 2 (permalink) Old 12-10-05, 02:13 AM
Registered User
Join Date: Nov 2005
Posts: 42
Re: 1992 Automatic Transmission help

Could possibly be the modulater valve or a vacuum problem in the same area.
mtneer57 is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome