1993 ranger 2.3 runs bad, please help. - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Ranger Forum Forum for discussion of the Ford Ranger.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-18-2010, 14:56   #1 (permalink)
Registered User
 
Join Date: Mar 2010
Posts: 7
1993 ranger 2.3 runs bad, please help.

I have a 1993 Ranger XLT 2.3L as of this morning I have a bad problem. All of a sudden driving it this morning it just started running really bad. I thought maybe i was running out of gas cause the gauge doesnt work so i filled her up but it didnt help. Long story short the truck idles bad, wont run right when i try to drive it it automatically wants to stall out. I checked all the vacum lines, i replaced the fuel filter and put new plugs on her and it still doesnt help. I was vibrating and shaking really bad i adjusted the idle screw up a bit to try to help but it doesnt work.

Now i replaced the head gasket a while back on it and new to the ranger im not positive i timed it right however it has been running good up until now. Also it has no manifold gaskets in it or throttlebody gasket just rtv. I know i know. Any opinions and help would be greatly appreciated.
cobracarlo is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-18-2010, 17:03   #2 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,719
Re: 1993 ranger 2.3 runs bad, please help.

You could try cleaning the MAF with MAF cleaner. That often helps. Also check for any vacuum leaks. Check the vacuum reading at idle.
__________________
Bert
Bert is offline   Reply With Quote
Old 03-18-2010, 19:51   #3 (permalink)
Registered User
 
Join Date: Mar 2010
Posts: 7
Re: 1993 ranger 2.3 runs bad, please help.

thanks man, i just cleaned the maf the other day but ill try again. Whats the vacum suppose to be at idle?
cobracarlo is offline   Reply With Quote
Old 03-18-2010, 20:45   #4 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,719
Re: 1993 ranger 2.3 runs bad, please help.

Idle vacuum should be around 20" and steady. See if you can remember where the idle screw was and put it back. It shouldn't be changed.
__________________
Bert
Bert is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 10:36.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.