1994 Ford Ranger a/c problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Ranger Forum Forum for discussion of the Ford Ranger.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 06-14-2010, 14:43   #1 (permalink)
Registered User
 
Join Date: Jun 2010
Posts: 13
1994 Ford Ranger a/c problem

Hello I have a similar problem I have a 1994 Ford Ranger XLT 4cly. There is no power getting to the compressor. I have tested both limit switches. All fuses and switch on the inside control. I jumped the compressor from the battery and the compressor ran and blew cold air. Why would there be no power going to the main lead on the compressor? Also when you press the power button to turn it on the engine speeds up as it would if the compressor would kick on but is not engaged. Any solutions? Thanks
JROE32 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-14-2010, 17:10   #2 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,727
Re: 1994 Ford Ranger a/c problem

Here's the wiring diagram for that part of the circuit. There should be power on the yellow wire at the switch and purple when the switch is on. There would then be power at the cycling switch. Have you gotten that far and all is good?
__________________
Bert
Bert is offline   Reply With Quote
Old 06-14-2010, 18:48   #3 (permalink)
Registered User
 
Join Date: Jun 2010
Posts: 13
Re: 1994 Ford Ranger a/c problem

Ok how do I go about testing those wires? Are you refering to the switch inside the truck that controls the blower and a/c? For some reason there is no power at the little black box shaped fuse under the hood the A/C WOT Relay. Thanks
JROE32 is offline   Reply With Quote
Old 06-14-2010, 20:11   #4 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,727
Re: 1994 Ford Ranger a/c problem

Whatever you're using to test for power, use it to test those wires at the switch (inside control) like I mentioned. Post back the results.
__________________
Bert
Bert is offline   Reply With Quote
Old 06-15-2010, 08:11   #5 (permalink)
Registered User
 
Join Date: Jun 2010
Posts: 13
Re: 1994 Ford Ranger a/c problem

Ok I have power to the yellow wire and when the button for the a/c is pushed in power to the purple.
JROE32 is offline   Reply With Quote
Old 06-15-2010, 08:35   #6 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,727
Re: 1994 Ford Ranger a/c problem

Then there should be power to the pin on the pressure switch. That should have power on both with freon in the system. That sends power to the relay. The relay is controlled by the PCM. That connects the dark green wire to the black/yellow wire that goes to the clutch.
__________________
Bert
Bert is offline   Reply With Quote
Old 06-15-2010, 11:29   #7 (permalink)
Registered User
 
Join Date: Jun 2010
Posts: 13
Re: 1994 Ford Ranger a/c problem

OK now power comeing from the dark green wire. Does that mean the pcm needs to be replaced? Also wouldnt other things be running wrong if the pcm was bad? Do you happen to know the price for the pcm also

thank you
jason
JROE32 is offline   Reply With Quote
Old 06-15-2010, 11:30   #8 (permalink)
Registered User
 
Join Date: Jun 2010
Posts: 13
Re: 1994 Ford Ranger a/c problem

sorry no power from the dark green that is
JROE32 is offline   Reply With Quote
Old 06-15-2010, 11:51   #9 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,727
Re: 1994 Ford Ranger a/c problem

There's power at the purple and none on the dark green at the pressure switch?
__________________
Bert
Bert is offline   Reply With Quote
Old 06-15-2010, 18:17   #10 (permalink)
Registered User
 
Join Date: Jun 2010
Posts: 13
Re: 1994 Ford Ranger a/c problem

Sorry there is power I had the battery unhooked
JROE32 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 00:40.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.