1996 Ford Splash 3.0, Auto Just died as I was driving - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Ranger Forum Forum for discussion of the Ford Ranger.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 12-31-2008, 19:01   #1 (permalink)
Registered User
 
Join Date: Dec 2008
Posts: 2
Lightbulb 1996 Ford Splash 3.0, Auto Just died as I was driving

I recently purchased a 1996 ford splash ranger with a 3.0 and automatic transmission. Since I first bought it , it's been alittle cold natured but that's typical, I guess.But as I was driving tonight I was turning and the engine died as I was slowing down to turn the engine died. I put it in neutral and it restarted as normal.
Then on my way back it had been running about 20 mins on the road and the engine died with no warning, just the dash lights came on and I coasted into a parking lot. I tried two times shortly to restart but it didn't. I waited another 5 mins and it started up and ran like a champ the next two miles home with no hesitation.It now scares me thinking I'm going to be stuck if I drive it anywhere else. I can turn a wrench and replace most anything but need a clue what to look for?
I would greatly appreciate any suggestions on your part since I know there must be other rangers that have done this. Oh about 3 yrs ago the engine was replaced with a remanufactured engine 3.0 also.
Thank you
Oh it's a two wheel drive.
Splashed is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-04-2009, 09:28   #2 (permalink)
canuck
 
360ci's Avatar
 
Join Date: Nov 2007
Location: Waterloo
Posts: 2,475
Re: 1996 Ford Splash 3.0, Auto Just died as I was driving

I'd get the truck scanned for any computer codes. Even with the light not on they can still be stored for up to 100re-starts. If no codes exist I'd start with the basics, such as tune up with new plugs & wires. If that doesn't help it, try replacing the IAC (idle air control) and TPS (throttle position sensor).
__________________
'00 Durango R/T 360ci 290hp (modded); 138,500m
'06 Pontiac G6 GT 3.5L 220hp; 44,000m
'12 Chrysler 200 Limited 3.6L 283hp; 13,000m
'99 Taurus 3.0L 2V Vulcan 145hp; 154,300m - Traded
Amsoil in all vehicles!
360ci is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 09:28.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.