2.3 I4 in a '78 Ford Courrier - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Ranger Forum Forum for discussion of the Ford Ranger.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 10-26-06, 12:38 PM Thread Starter
Registered User
 
Join Date: Oct 2006
Posts: 3
2.3 I4 in a '78 Ford Courrier

Ok well i just boght this truck, for like 200 $$, anyways i need it running for the winter. then only this is, it has an external regulator. and some of the wiring is messed up, so i keep blowing the regulator fuse. i just replaced the whole regualtor box thing.. so what else could it be? should i get a new alternator?

and im new to this forum, so if im in the wrong section just tell me where i need to go to get answers.



" 99 Civic - My Baby "
" 78 Courier - Work In Progress "
Taylo_Made07 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 10-26-06, 05:51 PM
Always the student
 
thefonz's Avatar
 
Join Date: Jul 2006
Posts: 1,738
Re: 2.3 I4 in a '78 Ford Courrier

I'd take them both off and have them tested at parts house. Post back with results and we will go from there.
thefonz is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome