2000 ford ranger 2.5L - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Ranger Forum Forum for discussion of the Ford Ranger.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 04-05-11, 02:57 AM Thread Starter
Registered User
 
Join Date: Apr 2011
Posts: 1
2000 ford ranger 2.5L

I have a 2000 ford ranger 5 speed manuel, the motor was replaced about 4 years ago with a motor that had less then 30,000 on it so my motor doesn't have over 90,000 on it, but anyways, i was driving home one day and it just shut down on me and i let it sit for a bit and it started and got home and it will only stay running when its cool but after about 10 mins when it warms up it'lll start missing real bad and then shut down, it's got a terrible idle to, but when your in the trottle it run's normal, well atleast before it warms up. here's a video i uploaded that will show a little what its doing.

I also have proper fuel pressure, and all the plugs have spark.


p.s. ingore that spark wire hanging there i just never took it off the plastic clap, i had to put a different wire on because when i pulled the old one off the medal piece in the inside broke off, so i do have all the wire's connected properly.
k3nny42o is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 04-05-11, 05:07 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,281
Re: 2000 ford ranger 2.5L

Autozone will check codes for free. See what you get with that.

Bert
Bert is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome