2000 pinging. - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Ranger Forum Forum for discussion of the Ford Ranger.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-14-2007, 17:30   #1 (permalink)
Registered User
 
Join Date: Dec 2005
Posts: 49
2000 pinging.

My 2000 3.0 flex is once again pinging and bogging. I recently dropped the $550 for the PCM and ignition coil that Ford said was a big problem with the 2000 flex engines, I did that about a month ago and the truck has been running like a top, take it up a hill at 40 to 45 no pinging. Today I had to pass some asshole at about 45 and I put the pettle to her and I get pinging... Its got 81,000 on it and the only thing at this point that has not been serviced is the fuel filter. I also know that the MAF has never been touched, but its not giving me a check engine light so im not sure if that could be dirty or what. Anyone else encounter this kind of crap before?
MadModderModa is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-18-2007, 15:09   #2 (permalink)
Registered User
 
dryelf327's Avatar
 
Join Date: Sep 2006
Location: Houston
Posts: 105
Re: 2000 pinging.

First thing I would do is clean the MAF. I'm not sure but I think they only trip a code if they malfunction like sending an off voltage signal back to the computer, not if they're dirty. Cleaning it should be regular maintenance anyway. I cleaned mine in my '98 Vic and notice about a 1-2mpg increase! Dirty MAFs will definitely cause pinging. You can get MAF cleaner at a auto store for like 5-7 bucks. What octane are you running? If you're running 87, try going up to 91 or 93 to see if that alleviates it. If it does, you probably have a lot of carbon build up in your combustion chambers. I would suggest running a seafoam treatment at that time to clean out the top end. Good luck.
__________________
My Fords:
'98 Crown Vic LX
-167k miles and counting. Still used as daily driver.

'99 Crown Vic Police Interceptor
-Completed full PI swap
-Marauder Airbox & 80mm MAF
-'04 CVPI Ziptube
-ADTR ported plenum
-Steeda Intake Spacer
-BOC tune
-J-Mod tranny
dryelf327 is offline   Reply With Quote
Old 07-20-2007, 00:29   #3 (permalink)
issuer of free advice
 
mre_power's Avatar
 
Join Date: Nov 2006
Location: la la land
Posts: 231
Re: 2000 pinging.

if cleaning maf dont work, try a new dpfe sensor, alot of 3.0 Vulcan engine owners with a pinging problem report a fix after they get a plastic dpfe sensor.
mre_power is offline   Reply With Quote
Old 07-21-2007, 11:23   #4 (permalink)
Registered User
 
Join Date: Dec 2005
Posts: 49
Re: 2000 pinging.

Thanx much guys I will try that stuff and see if it helps.
MadModderModa is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 11:00.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.