2000 Ranger 4x4 - Wheels Froze - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Ranger Forum Forum for discussion of the Ford Ranger.

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 02-24-11, 02:06 PM Thread Starter
Registered User
Join Date: Feb 2011
Location: St Paul
Posts: 1
2000 Ranger 4x4 - Wheels Froze

Hey there - new member to the Ranger community here.

We had about a foot and a half of snow on Monday. I have a Ranger XLT 4X4 6cyl with auto transmisison. I put the transmission in 4 wheel drive and after one block the front and rear wheels froze up. The transmisison was grinding badly. I shut the engine off to get it in park. The truck started but the transmisison would just grind.

The shop called and said that today they were able to drive it with just some slippage. They didn't do anything to it.

Any ideas on what would cause the wheels to freeze up and the transmission to stop working?

Any help would be appreciated.
Hughes200 is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome