2001 Ranger check engine 0401 - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
¬Ľ Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Ranger Forum Forum for discussion of the Ford Ranger.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-31-2004, 12:44   #1 (permalink)
Registered User
 
Join Date: Mar 2004
Location: Kansas
Posts: 2
Question 2001 Ranger check engine 0401

I'm getting a recurring Check Eng light on my 2001 Ford Ranger 4.0L 4x4 with 0401 code (EGR low flow) according to autozone.

The engine is pinging under load (even when engine is cold), otherwise running good/starting fine. Replaced EGR valve and EGR Solenoid and still occured. I then connected a hand vacuum pump to EGR valve and it seems to work (idle craps out). I disconnected the idiotic Vapor Managment Valve (on same vaccum source as EGR) as this valve does not seem to hold a vacuum, but I am still getting check engine after driving 5-10 miles. I thought with the VMV vacuum disconnected I might see an EVAP code or check fuel cap, but still just seeing the EGR fault.
ozarkracer is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-06-2004, 14:26   #2 (permalink)
Registered User
 
Join Date: Mar 2004
Location: Kansas
Posts: 2
Re: 2001 Ranger check engine 0401

I replaced the DPFE sensor and have driven about 100 miles with no check engine light. I am still getting pinging under light loads, could be the carbon problem. I was hoping getting the EGR working would stop it as it reduces the combustion chamber temp.

I am leary of that carbon procedure which flushes the crap out of the engine and could mess up 02 sensors or who know what. But its got 94K miles of highway cruising, so with the overdrive could have created a lot of carbon buildup.
ozarkracer is offline   Reply With Quote
Old 05-03-2004, 10:20   #3 (permalink)
Registered User
 
Join Date: May 2004
Location: Pennsylvania
Posts: 1
Re: 2001 Ranger check engine 0401

My '02 Ranger Edge 4.0L 4x4 has similar problems after 39K miles.
valves rattle usually when its warming up (5 to 10 minutes). The check engine light just came on. I get oil changes and service from the dealer every 4k-5k miles. The PVC was changed-out at 30K. Could this be from bad-gasoline? I always run 87-octane.
TEDDYO is offline   Reply With Quote
Old 05-03-2004, 13:38   #4 (permalink)
Registered User
 
Join Date: Apr 2004
Posts: 3
Re: 2001 Ranger check engine 0401

I had the same code with my 96 Ranger. I replaced the egr valve and had code reset. A day later it came back on. I went down this past friday night and put 94 octane gas in it and the pinging immediately went away. The check engine light went off after driving it a little bit the next day. I know gas is expensive these days but a little better fuel may be all you need.
sdrummer2 is offline   Reply With Quote
Old 05-22-2004, 10:59   #5 (permalink)
Registered User
 
Join Date: May 2004
Posts: 8
Re: 2001 Ranger check engine 0401

Quote:
Originally Posted by ozarkracer
I'm getting a recurring Check Eng light on my 2001 Ford Ranger 4.0L 4x4 with 0401 code (EGR low flow) according to autozone.

The engine is pinging under load (even when engine is cold), otherwise running good/starting fine. Replaced EGR valve and EGR Solenoid and still occured. I then connected a hand vacuum pump to EGR valve and it seems to work (idle craps out). I disconnected the idiotic Vapor Managment Valve (on same vaccum source as EGR) as this valve does not seem to hold a vacuum, but I am still getting check engine after driving 5-10 miles. I thought with the VMV vacuum disconnected I might see an EVAP code or check fuel cap, but still just seeing the EGR fault.
Had a diagnistic on my '99 2.5. Replaced plugs, plug wires, and mass air flow sensor. It was okay for 500 mi, then began pinging again. Replaced O2 sensor w/o further diagnostic. Now it only pings uphill on a long grade. Haven't tried gas lower than middle octane grade yet but it's better than the premium I used to need.
mikhael is offline   Reply With Quote
Old 05-22-2004, 19:23   #6 (permalink)
Registered User
 
Join Date: May 2004
Posts: 7
Re: 2001 Ranger check engine 0401

I have the same problem. I have the check engine light on, replaced wires, plugs. And still the check engine light is on. I have rough idle and loss of power. Dont know what to do now...someone help!
romura is offline   Reply With Quote
Old 05-23-2004, 09:40   #7 (permalink)
Registered User
 
Join Date: May 2004
Posts: 8
Question Re: 2001 Ranger check engine 0401

Quote:
Originally Posted by mikhael
Had a diagnistic on my '99 2.5. Replaced plugs, plug wires, and mass air flow sensor. It was okay for 500 mi, then began pinging again. Replaced O2 sensor w/o further diagnostic. Now it only pings uphill on a long grade. Haven't tried gas lower than middle octane grade yet but it's better than the premium I used to need.
Update: One week later, no pinging. Still using middle grade gas. This truck shoud run on regular. Considering reinitializing the computer with a power off.
any input?
mikhael is offline   Reply With Quote
Old 05-23-2004, 11:29   #8 (permalink)
***** Idiot....
 
LunaticSVT's Avatar
 
Join Date: Feb 2001
Location: The Sticks of Central TX
Posts: 10,561
Re: 2001 Ranger check engine 0401

A vacuum leak can cause pinging. If the EGR valve is not seating closed, it is the same as a vacuum leak. Look for any other possible vacuum leaks also.
LunaticSVT is offline   Reply With Quote
Old 05-25-2004, 21:53   #9 (permalink)
Registered User
 
Join Date: May 2004
Posts: 8
Re: 2001 Ranger check engine 0401

Quote:
Originally Posted by romura
I have the same problem. I have the check engine light on, replaced wires, plugs. And still the check engine light is on. I have rough idle and loss of power. Dont know what to do now...someone help!

Try checking for loose vacum hoses, gas cap, oil filller cap etc. If all else fails spring for a pro diagnostic. Good luck.
mikhael is offline   Reply With Quote
Old 05-25-2004, 21:57   #10 (permalink)
Registered User
 
Join Date: May 2004
Posts: 8
Re: 2001 Ranger check engine 0401

Quote:
Originally Posted by LunaticSVT
A vacuum leak can cause pinging. If the EGR valve is not seating closed, it is the same as a vacuum leak. Look for any other possible vacuum leaks also.
Thanks. Will try a ew EGR. Also, there's a vacum hose that looks suspect. I'll post the result.

Mikhael
mikhael is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
check engine code waxtadpole Ford Ranger Forum 11 11-01-2003 12:16
2000 Ranger: ABS, Check Engine light on, no speedometer! anton1117 Ford Ranger Forum 6 09-06-2003 18:37
Holdens new V6 EED-250 The Pub 52 08-09-2003 22:07
2003 Ford Ranger FX4 Level II Stacy94PGT Ford Ranger Forum 1 05-11-2003 21:15
New 2004 Ranger Builds On 16 Years Of Leadership RPO83 Ford Worldwide News 0 04-15-2003 05:36

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 11:03.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.