2003 2.3l tranny probs........ - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Ranger Forum Forum for discussion of the Ford Ranger.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 04-22-2012, 13:36   #1 (permalink)
Registered User
 
Join Date: Oct 2010
Posts: 25
2003 2.3l tranny probs........

My son's truck did the following today after getting it back from a headgasket fix. The truck is a 2003 2.3 duratec automatic with 150k miles.

He went to pull out into traffic and it just revved. Like it was in neutral. He put into second manually and made it back home. No OD light flashing.

Two hours ago he drove it again. This time it lagged at first while in drive and then went into first and drove normally BUT the OD light is flashing now.

Where do I start? I tried to pull a code and there isn't one this morning.

Now when in D, it barely moves.......same for reverse. BUT 1st and 2nd work fine.

Is there something I check that may have came loose after being worked on? He drove it for about 50 miles before this happened last night.

Thanks so much!
justin murphy is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-23-2012, 06:50   #2 (permalink)
Registered User
 
Join Date: Oct 2010
Posts: 25
Re: 2003 2.3l tranny probs........

Anyone? Please.
We just got it back from the headgasket repair and then a day later. Really?

The mechanic we use says he doesn't deal with transmissions so I do trust him.
justin murphy is offline   Reply With Quote
Old 04-23-2012, 20:25   #3 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,809
Re: 2003 2.3l tranny probs........

Those are hard to diagnose. It could be as easy as the transmission range sensor. You could try cleaning the contacts and make sure it's plugged in good. They used to be the neutral safety switch.
__________________
Bert
Bert is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 12:11.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.