2008 Ranger Factory HU - HELP PLEASE! - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Ranger Forum Forum for discussion of the Ford Ranger.

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 08-14-07, 08:46 PM Thread Starter
Registered User
Join Date: Aug 2007
Posts: 2
2008 Ranger Factory HU - HELP PLEASE!

I have a 2008 Ranger XLT that I purchased just last week. I recently attempted to install a Jensen VM9311TS in-dash DVD player. After removing the factory CD player, connecting the harness cables, etc, I powered on the vehicle for the deck to not initialize, but it does receive power because when the power button is pressed, a beep sounds. I assumed that this may be caused by the fact that I neglected to install the parking break sequence wire as i saw it as beyond my ability, and I have the unlock code. So, after coming to the conclusion that I couldn't handle the installation, I decided to remove the DVD deck and replace it with the original factory one until I could get it professionally installed. When I turned the vehicle on to test the factory deck after my re-install of it, it illuminated, and displays the time(the wrong time) for about 10-15 seconds then times out, but it can be turned on by pressing clock on the deck. I assumed that this was due to a security feature imposed by Ford on the CD players, so i called, but there was no security feature in my vehicle. So now I am stuck with a factory deck that only displays the time, accepts and ejects CD's, and illuminates.
My conclusions are that it clearly has power on account that it displays the time and ejects CD's etc.


Please be of some assistance..
What are some possible problems that could be causing this?
Or if you have any ideas for me to attempt, that would be appreciated!

Thanks alot!

PS: If anyone provides the solution that fixes this problem, I will send them a small token of my appreciation VIA PayPal..
c_taylor89 is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome