3.0 Hard start - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Ranger Forum Forum for discussion of the Ford Ranger.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 09-19-07, 01:33 PM Thread Starter
Registered User
 
Join Date: Jun 2006
Posts: 4
mad 3.0 Hard start

Hey guys, so I have a 2003 ranger 3.0 regular fuel.. For the past few weeks I have been having this hard start problem. If you crank it once, it wont fire, crank again maybe, but the third time is always a charm.. At first I have no 3 second pulse from the pump with the key on. 0psi on the fuel pressure gauge. Turn the key on again and you get 5-10 psi. The third time you get about 20psi and it will fire. Once it is running I have about 55-60 psi at the schrader valve. Oh and yes, I did change the fuel filter.. I am pulling my hair out! So before I head on over to the dealer, any suggestions would be greatly appreciated! Thanks so much

66comet is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 09-19-07, 03:13 PM
Registered User
 
Join Date: Nov 2005
Posts: 42
Re: 3.0 Hard start

That is a head scratcher, don;t know for sure but I will throw a few things at ya. Dont know if a relay can stick but you have a fuel pump relay, you also have a fuel pump cut out switch, fuel pressure regulator, or your pump could be about to die.
mtneer57 is offline  
post #3 of 4 (permalink) Old 09-20-07, 04:34 PM
Registered User
 
Join Date: Aug 2007
Posts: 42
Re: 3.0 Hard start

sounds like u may have a fuel pump going out, i doubt its the fuel pump relay, if so, the pump wouldnt be kicking on at all, good luck
ford_ranger_88 is offline  
post #4 of 4 (permalink) Old 09-22-07, 08:28 PM Thread Starter
Registered User
 
Join Date: Jun 2006
Posts: 4
Re: 3.0 Hard start

thanks so much guys, I have been killing myself over this, maybe it is time to go spend the 100 bux down at the dealer and have them diagnose it. I will let you know what I find.
66comet is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome