85 ford ranger 4x4 carborated v6 - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Ranger Forum Forum for discussion of the Ford Ranger.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-08-2009, 23:46   #1 (permalink)
james
 
Join Date: Feb 2009
Location: hawaii
Posts: 8
85 ford ranger 4x4 carborated v6

i have a 1985 ranger corbarated but it runs crappy heres the low down it stARTS but it dosent want to stay running i have to floor the gas pedal just to keep it running and then it just boggs out i dont get it at all so please help but if it starts that would mean that i have spark right i have no what is wrong pleas help
semaj_96734 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-09-2009, 11:13   #2 (permalink)
Administrator
 
Join Date: Sep 2006
Location: Arkansas
Posts: 6,110
Re: 85 ford ranger 4x4 carborated v6

Could be a stopped up fuel filter.
jwko is offline   Reply With Quote
Old 02-10-2009, 14:15   #3 (permalink)
james
 
Join Date: Feb 2009
Location: hawaii
Posts: 8
Re: 85 ford ranger 4x4 carborated v6

i changed the fuel filter i didnt help at all
semaj_96734 is offline   Reply With Quote
Old 02-10-2009, 14:23   #4 (permalink)
james
 
Join Date: Feb 2009
Location: hawaii
Posts: 8
Re: 85 ford ranger 4x4 carborated v6

could it be a blown fuse or somthing causing this problem what would i do next since i ive got the fuel filter out of the way
semaj_96734 is offline   Reply With Quote
Old 02-16-2009, 21:27   #5 (permalink)
Registered User
 
Join Date: Feb 2009
Posts: 5
Re: 85 ford ranger 4x4 carborated v6

i had the same problem with my 85 4x4 when i first got it.when you cranked it it would idle but if you tried to take off forget it.i was told it was the vaccum, then i was told the filter,the another mechanic told me to check the float and needle valve.my truck has a motorcraft two barrel.so i bought a used carburator at a junk yard for 20 bucks and bought a rebuild kit for about 30 to 40 bucks at napa.now my truck runs fine.i rebuilt the other original and sold it and it runs like new.it could be that your pump is dry rotted or the small bb thats in there could have got stuck either way.if youl take the time to rebuild it youll probably solve your problem.it takes about 3hrs.get a can of ether,carburator cleaner,and the kit.the kit gives you step by step instructions for tear down and assemble.try that or visit a local junk yard and find one that runs the bronco 2 have the same carburators as well.hope this helps.
kfant is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 14:14.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.