88 Ford Ranger Not Running With Help! - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Ranger Forum Forum for discussion of the Ford Ranger.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 09-12-05, 08:18 AM Thread Starter
Registered User
 
Join Date: Sep 2005
Posts: 4
Question 88 Ford Ranger Not Running With Help!

My sons ford ranger 2.9 with dual pumps will not run on its own! Has anybody else had a problem with the pumps not running? We had to replace the booster pump and the pressure regulator! Replaced relay switch, O2 sensor but still will not run! Any ideas to the problem? Tested power sourses to relay working okay except the relay switch will not engage! Apply ground to oppsite side of relay comming from EEC and the truck will run! I am not sure if the EEC is the problem is there some test that I can perform with out a Computer Engine test?

#1Truckfarmer is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome