88 Ranger! Ignition Problem? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto EscrowInsurance

Ford Ranger Forum Forum for discussion of the Ford Ranger.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 06-13-2009, 07:12   #1 (permalink)
Registered User
 
Join Date: Jun 2009
Posts: 1
88 Ranger! Ignition Problem?

I got an 88 ranger 4x4. i have recently had some problems with the truck not getting fuel. It runs great, no missing or anything, but out of no where it will just shut off without warning. Turns out when it suddenly shuts off the fuel pump was not kickin on. So, i assumed it was the fuel pump that was messing up. I put a new fuel pump on it, and put it back together and everything worked fine until again, out of no where, it shut off and the fuel pump was not working. I've tried tracing the wires from the pump and they all go into the firewall, so i'm guessing they go to the ignition?

Just wondering if anyone has had this happen, or might know what the problem is with this? I asked a family friend, who is a mechanic, what he thought the problem was at first and he said maybe an ignition problem, but i was stuck on the pump going bad...

Any advice or info would be greatly appreciated..
onebad86gt is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 04:03.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.