89 ranger Dual Plug input control code - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Ranger Forum Forum for discussion of the Ford Ranger.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 07-26-10, 05:06 PM Thread Starter
Registered User
 
Join Date: Jul 2010
Posts: 1
Question 89 ranger Dual Plug input control code

I am a newbie and need some expertise

1989 Ford Ranger 4 Cyl 2.3L, 5speed 4X2 Dual plug ignition

The induction side spark plugs are not firing at all at any time.
The engine runs continuously on the right side spark plugs.
My KOEO codes are:
33 - EGR Valve opening not detected
41 - No HEGO switch detected
88 - Loss of Dual Plug input Control
My Engine Running codes are:
98 - Hard Fault Present
88 - Loss of Dual Plug input Control

What I have accomplished so far:
New Plugs
New Wires
New ( both) coil packs
New DIS Ignition Module

Still the driver's side coil pack does not produce a spark.

The quick connector harness wires that plug into the driver's side coil pack don't appear to have any electrical current flowing while the truck is running.

The hard fault code (98) is probably referring to code 88.

How can i troubleshoot further back to find the problem?

flhosen is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 07-26-10, 05:22 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,311
Re: 89 ranger Dual Plug input control code

Here's a good write-up on it. My Ford 94 Ranger has an intermittent check engi... - JustAnswer

Bert
Bert is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome