93 Ranger Heater Core - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Ranger Forum Forum for discussion of the Ford Ranger.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 05-15-07, 08:39 AM Thread Starter
Registered User
 
xflashx's Avatar
 
Join Date: May 2007
Posts: 2
93 Ranger Heater Core

I'm just curious if anyone else has had a problem with the Heater core? This is the 2nd time I've replaced it I'm just wondering why it's breaking so much.

xflashx is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 05-15-07, 09:57 AM
issuer of free advice
 
mre_power's Avatar
 
Join Date: Nov 2006
Location: la la land
Posts: 231
Re: 93 Ranger Heater Core

maybe your replacement was a defective one. remember it was made to be made as cheap as possible. i would only be concerned if it happened again. but you can borrow a coolant system pressure tester from autozone if one is near by to see if there are issues with your coolant system.
mre_power is offline  
post #3 of 3 (permalink) Old 05-15-07, 10:01 AM Thread Starter
Registered User
 
xflashx's Avatar
 
Join Date: May 2007
Posts: 2
Re: 93 Ranger Heater Core

I've have taken into account that it was made as cheap as possible... I never thought about the pressure tester. Thanks for the info
xflashx is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome