94 ranger b2300 runs rough in warm weather - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Ranger Forum Forum for discussion of the Ford Ranger.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 09-20-09, 08:59 AM Thread Starter
Registered User
 
Join Date: Sep 2009
Posts: 1
94 ranger b2300 runs rough in warm weather

Have been trying to sort out this truck with only 2 original parts left that havn't been replaced. Mass air sensor and map sensor. Coil packs were replaced at some time before I got this truck.
Have tryed cleaning the maf sensor ran ok for a minute then back to stalling.
I've resorted to yturning it off in traffic and restarting it.
If its a cold day it runs fine unless I drive it for several hours...on a hot day it starts in a few minutes. The engine light comes on during the wrough idle but
it has to be running rough to see what the code is as it doesn't stay in memory..not a hard code. Any ideas much appreciated...

edsranger is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 09-20-09, 09:43 AM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,326
Re: 94 ranger b2300 runs rough in warm weather

Try cleaning the IAC. Did you use the cleaner made for the MAF?
Bert is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome