'95 Ranger V6 just DIES PLS HELP!! - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
» Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Ranger Forum Forum for discussion of the Ford Ranger.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-06-2008, 11:30   #1 (permalink)
Registered User
 
Join Date: Dec 2005
Posts: 2
mad '95 Ranger V6 just DIES PLS HELP!!

My '95 V6 Ranger just dies unexpectedly, happened several times over two years. Mostly in stop / go traffic or pulling in to park. First two times, it started after sitting for a few hours, or overnight. Last two times, however, I’ve had to charge the battery then it starts up again and I drive several months till it happens again. Whatever is happening seems to cause the battery to drain down after the “death”. The batt is quite new and truck runs fine other than for this mystery thing.
This Friday pulling in to park, I noticed the clutch got tight, then the engine just died, and would not start. No cranking, no nothing. This time -at night, with all switches off we noticed interior dome and exterior rear cab top lights were ON. Had to leave her parked overnite, towed home next morning and charged the half discharged battery then she started up.
I’ve had the non stop door ding problem. Fixed that, and still have ocaisional ghost wiper / washer turn on, so I should probably replace the GEM? but any help on this intermittent engine death thing would be VERY much appreciated.
RB / SP
RangerBen is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-15-2008, 06:23   #2 (permalink)
Registered User
 
Join Date: Dec 2007
Posts: 37
Re: '95 Ranger V6 just DIES PLS HELP!!

well there are a couple of possibilites first have you checked you alternator to insure it putting out 14 volts or higher. if it is you may want to have it bench tested to insure it can handle a load
gmaier is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 01:13.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.