96 ranger 4 l. - elec. ok -won't kick over - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Ranger Forum Forum for discussion of the Ford Ranger.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 09-14-07, 10:08 AM Thread Starter
Registered User
 
Join Date: Sep 2007
Posts: 1
96 ranger 4 l. - elec. ok -won't kick over

96 ranger 4 l.

elec. pwr to all systems. starter won't kick over.

jumped once. started.

started 1 hour ago. drove around. came home. sat 1 hour. now won't start now.

"click" at turn of igniton but no cranking.

new battery, new alternator.

no indication of starter wear. never failed until yeterday. has failed to start twice in two days.

low humidity.

ozziekrick is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 09-17-07, 09:42 PM
Registered User
 
Join Date: Aug 2007
Posts: 5
Re: 96 ranger 4 l. - elec. ok -won't kick over

Check the terminals. Sounds dumb. But it happened to me the other day on my 96 Ranger. I was scared to death it was my alternator. The terminal actually developed a kink and quit working after some time. I replaced them both and is fine now.
FORD#740MX'ER is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome