97 4.0 Ranger Oil Disappearing - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Ranger Forum Forum for discussion of the Ford Ranger.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 12-13-2005, 16:11   #1 (permalink)
Registered User
 
Join Date: Dec 2005
Posts: 1
97 4.0 Ranger Oil Disappearing

This is my service vehicle.
It has approx 90K on it.

It had oroginally being using approx 1qt every time I changed the oil at 3K.

Suddenly, I discovered it had been using approx 2-3qts per change.
When I discovered this, I changed the pcv valve.
It didn't help and, the old one was loose anyway.

I went over it for leaks and found none.
Nor are there any spots on my driveway.

I've had it in to the dealer where I purchased it and, I was told that it needed the valve seals replaced.
Well, they did that.

Now it uses EVEN MORE oil than before they changed the seals.
I took it back & they told me they checked to see that the seals were good and told me that they were.

It is STILL using oil at an accelerated rate and, it does NOT smoke as if it's burning oil.

I'm hesitant to take it elswhere and pay AGAIN for whatever BS I'll be told.

As I said, this is my service vehicle(appliance repair) and, I do NOT play hotrod, nor do I carry a heavy load.

Any suggestions would be appreciated.
TOOLGUY is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 07:20.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.