98 Ranger...camshaft Position Sensor - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Ranger Forum Forum for discussion of the Ford Ranger.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 06-17-09, 05:57 PM Thread Starter
Registered User
 
Join Date: Jun 2007
Posts: 26
98 Ranger...camshaft Position Sensor

My truck has the lovely 2.5L 4cyl motor. About 2 weeks ago it tossed the code for the Camshaft Position Sensor Circuit Malfunction. I believe it's P0340.... I replaced the sensor with the greatest of ease. Today, it tossed the exact same code. I know the key words are "Circuit Malfunction" meaning it can be anywhere in the wiring. Can anyone give me any better ideas besides just tearing into the wires trying to find a grounded out or frayed wire? Or could it possibly (I highly doubt it) be a bad sensor? Maybe I should replace the sensor again? This is gonna drive me insane!!! Thanks in advance for all the help!!!

82fordguy is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 06-25-09, 04:00 AM Thread Starter
Registered User
 
Join Date: Jun 2007
Posts: 26
Re: 98 Ranger...camshaft Position Sensor

Ok, I figured I would post an update on my situation in case there are other people with this same problem.... The "CPS" has 2 wires connecting it, a blu/or and a red/grey. The blue and orange is a direct feed to the computer to pin 85. The red/grey includes other sensors on the same circuit going to pin 91. Seeing as how there was only the one code for the CEL, I knew that the wire causing the problem was the blu/or. I cut both ends of the wire, leaving them connected at the computer and the plug for the sensor, and spliced a new wire to it running away from the block so this will not happen again. This saved me alot of money from a repair shop of having to remove the AC Compressor and the power steering pump brackets. Hopefully this will help someone else!!
82fordguy is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome